Error: A mandatory tag is missing: Entity trading status (Current Period) in a FRS 102 client in Accounts Production Advanced

Scenario

You may get the following error message in your report:
Error message
A mandatory tag is missing: Entity trading status (Current Period) in a FRS 102 client in Accounts Production Advanced.

Cause

The cause of this error is likely be an issue with the master client.

Solution

  1. Open the client and select the
    Disclosure
    tab.
  2. Select the
    Financial Period Information and Exemptions
    link.
  3. Make sure the
    Trading
    or
    Non-Trading
    option is selected correctly.
  4. If the client is Non-Trading, choose from the
    Has the entity previously traded
    dropdown list.
  5. Select
    OK.
  6. Open the report and export it to HTML.
tip
If these steps don't solve the error, complete the Additional troubleshooting steps.

Additional troubleshooting

  1. Sign in to Accounts Production Advanced as Administrator.
  2. Select the
    Template Entities
    tab.
  3. Open the FRS 102 master client.
  4. Select the
    Reports
    tab and run the report which gave you the error the message.
  5. Check if the report that gives the error message is one of our default reports listed below:
    • All Account Codes.
    • Blank iXBRL Enabled Report.
    • Blank Report.
    • Category Summary – Balance.
    • Company Five Year Summary.
    • Consolidated Lead Schedules.
    • FRS 102 Consolidated Financial Statements.
    • FRS 102 Dormant Financial Statements.
    • FRS 102 Financial Statements.
    • FRS 102 Section 1A – Abridged Financial Statements.
    • FRS 102 Section 1A – Small Entities.
    • FRS 105 – Micro Entities.
    • Group Five Year Summary.
    • Journal Summary.
    • Lead Schedules.
    • Management Accounts.
    • Nominal Ledger.
    • Trial Balance.
    • Trial Balance by Classification.
    • Trial balance for export to Excel.
  6. If the report that causes the error is a default report:
    1. Select the
      Report Structure
      tab.
    2. If the
      Cover page
      folder is in bold, right-click it and select
      Revert to Template
      from the context menu.
  7. If the report that causes the error is not one of our default reports then it won't have been included in our update process, so you'll need to take the following steps to update the XML code manually:
    1. Select the
      Report Structure
      tab.
    2. Right-click
      Cover page
      and select
      Properties
      from the context menu.
    3. Select the
      XML Source
      tab.
    4. Delete all the XML code.
    5. Download one of the following text files that contain replacement XML code according to the report template that has caused the error:
    6. Paste all the XML code from the text file you've downloaded into the
      XML Source
      tab.
    7. Select
      OK
      .
  8. Select
    Financial Period Templates
    , then
    Publish Current Period as New
    .
  9. Open the client that you had open when you got the error, and select
    Update
    .
  10. Rerun the report and export it.