Error: no data to import for requested client when importing from Accounts Production Advanced into Corporation Tax

You may get the following error message when you import accounts from Accounts Production Advanced to Corporation Tax.
Error message
No data to import for requested client.

Cause

The issue may be caused by the clients in Accounts Production Advanced and Corporation Tax linking to different (duplicate) clients in Practice Management.

Solution

The client in Accounts Production Advanced and Corporation Tax need to be integrated with Practice Management for the import to work. To check this:
  1. Open the client in both applications and ensure the green
    Integration
    icon is showing in Accounts Production Advanced and the Corporation Tax client. 
  2. If the
    Integration
    icon is red or grey, then you will need to share the clients.
  3. You should make sure the client has exactly the same accounting period dates in the client in Accounts Production Advanced and Corporation Tax.
  4. Open the client in Accounts Production Advanced and select the blue
    General
    link.
  5. Select
    Edit
    to link to the Practice Management record. 
  6. Make a note of the client code and select
    Save and Close
    to return to the accounts.
  7. Open the client in Corporation Tax and select the blue
    Company Details
    link.
  8. Select
    Edit
    to link to the Practice Management record to see if it is the same Practice Management record the accounts were linking to.
  9. If there is duplication you will need to take the following steps to break the integration link to one of them:
    1. Delete one of the companies in Practice Management.
    2. Re-share the client from Accounts Production Advanced or Corporation Tax (whichever is now not linked via integration).