Error: Progress bar stuck paginating a report — System out of Memory Exception in Accounts Production Advanced

Scenario

If the progress bar of the report gets stuck on paginating for a long period when loading the report it is likely there is an element in the report which is stopping the report from loading successfully.

Causes

The likely cause of this problem is that a report element has too many columns to be shown in Portrait view.

Solution

Find the element in the report that causes the problem, then change that element to Landscape view.
  1. Select
    Cancel
    to stop the loading of the report.
  2. In the Report Structure, expand the
    Financial Statements
    folder, then clear the
    Notes to the Financial Statements
    checkbox
  3. Select
    Full Report
    from the toolbar.
    note
    If the report loads correctly then go to step 6.
  4. If report does not load correctly after step 3, clear the
    Financial Statements
    folder checkbox, then select
    Full Report
    from the toolbar.
    note
    This will tell you if it's a problem with one of the elements in the Report Structure between the
    Financial Statements
    folder and the
    Notes to the Financial Statements
    folder.
  5. Expand the
    Financial Statements
    folder, right-click on each of the sub-folders, then select
    Preview
    from the context menu.
    note
    If the preview gets stuck paginating, then the problem is with that element.  
  6. When you have identified the problem element, select it in the Report Structure, then mark the
    Change to Landscape
    checkbox.
  7. Select
    Full Report
    from the toolbar.