Error: Server busy in Personal Tax

Scenario

You may see the following error message in Personal, Business and Trust Tax.
Error message
Server busy.

Cause

The
Server busy
message is essentially a PC environment problem. In most cases we've analysed, it is Personal, Business and Trust Tax that waits for Windows to respond.
Personal, Business, and Trust Tax is more likely to be the victim of a problem with the operations of Windows than the cause of it. If you search the internet for information about the error message, you will see many suggested potential causes, but none implicate the application that reports the message.
We've found most occurrences are within RDP sessions in a Terminal Server environment or on locked down PCs where the users are not local administrators, and where group policy restrictions apply.

Solution 1: clear profile data

In most cases, the error will be solved if you clear the profile data.
  1. Close all Digita applications.
  2. Reboot your computer.
  3. Select the following link to download our Rename Profile Data ZIP folder.
  4. Right-click the downloaded ZIP file and select
    Extract All
    .
  5. Double click
    RenameProfileData.cmd
    .
  6. Try the applications again.
  7. If this solutions fails, ask your firm's IT professional for help to work through the further troubleshooting steps below.

Further troubleshooting steps

  1. If on a Terminal Server (RDP Session) the CPU utilisation is continually on or over 97%, the server might be overloaded.
  2. On the DB server, check for Application Event logs referencing '
    I/O is frozen on database msdb
    ' and '
    I/O was resumed on database msdb
    ' for each DB. This is a result of a backup process taking a server snapshot. The result will be '
    Server busy
    ' messages on the RDS servers and it will cause applications to crash.
  3. Software integrated into ‘Explorer’ of the computer tries to access network or online resources and is not able to. For example, antivirus software, Ipad/iTunes, Sun Java Updater, or any other program that has program update options.
  4. Check the networking setup is valid. Ensure IP v6 is disabled, The Gateway, DNS, and DHCP servers are all accessible and can be pinged.
  5. Some of the applications have an update notification which you could disable to eliminate it. Within the Digita applications, go to
    Tools
    , then
    Options
    or
    User profile
    ,
    Tools
    , then
    User Management
    .
  6. Make sure that Windows Authentication for sign in to Digita Applications is installed, whether it used or not. Go to
    Tools
    ,
    User Management
    and use the
    Manage Users
    or
    Database Security
    options.
  7. Change your Windows sign in security group to a local administrator to eliminate a possible permissions issue on the file system or registry. The user who is signed in may need installation permissions. Make sure that your antivirus is enabled for this.
  8. Disable Group Policy for the user.
  9. Sign in as an Administrator, run Personal, Business, and Trust Tax, then sign in as the user again.
  10. It's possible the cause is a corrupt Windows sign in profile, or restricted permissions on part of the user registry. Ask your IT Support to reset your Windows profile without data loss.
  11. Disable your anti-virus to check if effects the launch of Personal, Business, and Trust Tax.
  12. Run a Windows Update, install all updates available, reboot, and repeat until there are no more updates to apply.