Error: Unhandled exception vfpole provider not registered

Scenario

You may get the following error when you install the
Engagement Manager
conversion utility or when you convert data from
CaseWare Working Papers
or
ProSystem fx Engagement
to
Engagement Manager
, just after you are asked to log in:
Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately. Except has been thrown by the target of an invocation. Exception Text System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation... The 'vfpoledb' provider is not registered on the local machine...

Cause

Visual FoxPro OLE DB Provider
is a program that's installed by both
CaseWare Working Papers
and
ProSystem fx Engagement
to handle some data. If there's a problem with Visual FoxPro, it may cause a problem for the
Engagement Manager
conversion.

Solution

  1. Log in to the computer as an administrator.
  2. Select Windows Start, Control Panel, then Select Programs and Features.
  3. Find and uninstall the following items, if present:
    1. Engagement Manager Conversions
    2. Microsoft Visual FoxPro OLE DB Provider
  4. In Windows Explorer, go to the
    C:\Program Files
    folder. If the
    CSIConvert
    folder exists, rename it
    CSIConvertOLD
    .
  5. Download and install
    vfpoledb.exe
    from the Microsoft OLE DB Provider for Visual FoxPro 8.0 page of
    Microsoft
    's website.
    1. In the installation wizard Welcome screen, select
      Next
      .
    2. In the
      License Agreement
      screen, select
      I accept the terms in the license agreement
      , then
      Next
      .
    3. Review the information in the
      Readme Information
      screen, then select
      Next
      .
    4. In the
      Destination Folder
      screen, leave the default folder path as is, then select
      Next
      .
    5. Select
      Minimal
      in the
      Setup Type
      screen, then
      Next
      .
    6. Review the information on the
      Ready to Install Program
      screen, then select
      Install
      .
  6. Take the following steps to install the Engagement Manager Conversion utility:
    1. In
      Engagement Manager
      , select
      Setup
      , then
      Downloads
      .
    2. Choose the
      Caseware and ProSystem fx
      conversion utility link.
    3. Go to the
      Engagement Manager Competitive Conversions.exe
      file that you just downloaded.
    4. Right-click the file and select
      Run as administrator
      from the context menu.
    5. Select
      Yes
      when asked to allow the program to make changes to your computer, then follow the instructions to install the utility.
  7. After the installation is complete, attempt the conversion again.
  8. If the conversion succeeds, delete the
    CSIConvertOLD
    folder that you renamed in step 4.
Chat now

error-icon

Triva isn't available right now.

Check out the support page for our phone number and hours

error-close