Error: (399 [HY000]) Error in ProcessClientSync. System.Data.Odbc.OdbcException... ODBC--connection to 'GFR_DB_Lookup' failed...

Scenario

You may get an email with either of the following error messages multiple times per day. You may also notice the Lookup List Sync is not working properly and find these errors in the log files.
Error message
(
399
) Error in ProcessClientSync. System.Data.Odbc.OdbcException: ERROR [
HY000
] [Microsoft][ODBC Microsoft Access Driver]
ODBC--connection to 'GFR_DB_Lookup' failed
. at GFR_LookuplistSync.Database.Execute(String strSQL, String strDelimiter) at GFR_LookuplistSync.SyncLookuplist.ProcessClientSync(IniFile& objIniFile)
(
399
) Error in ProcessClientSync. System.Data.Odbc.OdbcException: ERROR [
HY000
] [Microsoft][ODBC Microsoft Access Driver]
Could not use '(unknown)'; file already in use
. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver] Could not use '(unknown)'; file already in use. at GFR_LookuplistSync.Database.Execute(String strSQL, String strDelimiter) at GFR_LookuplistSync.SyncLookuplist.ProcessClientSync(IniFile& objIniFile)

Cause

These errors may be caused by any of the following:
  • The server hosting the time and billing database is offline.
  • The time and billing database has moved to a different server that where it was when the lookup list and ODBC data source were originally set up.
  • A change to the firewall is not allowing the connection to the time and billing database.
  • Settings for the time and billing database server have changed and no longer allow remote connections.
  • The name of the time and billing database has changed.
  • The login defined in the ODBC connection to the time and billing database has failed.
  • If the Lookup List Sync utility is set to query an Access database, that database may be locked open.

Solutions

Solution 1: Connection to 'GFR_DB_Lookup' failed

Try these recommended solutions in the following order.
  • Verify that the server hosting the time and billing client database is online.
  • Verify that you are connect to the time and billing program database server.
  • Review the Practice CS SQL server troubleshooting article for resources and information on configuring the Practice CS SQL database.
  • Verify that there is an entry for GoFileRoom under System DSN for ODBC connections.
  • Test the ODBC datasource and update passwords or database names as necessary.
  • Review the ODBC Connection to a Database article for information on ODBC connections.

Solution 2: Could not use '(unknown)'; file already in use.

If you're unsure if the time and billing Access database is open, you can determine this by looking for database lock (.LDB) files, which prevent the utility from working.
Go to the location of the database's .MDB file, and look for .LDB files. If any are present, the database is open. We do not recommend removing the lock while someone is working in the database.

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