Error: Staff or client cannot be deleted because it is associated with historical data

Scenario

You may get the following error message when you try to delete a staff or client with history, data, or references to the client in the database.
Error message
The [client or staff] cannot be deleted because it is associated with historical data.

Cause

Practice CS lets you delete a client or staff only if there is no history or data of any type, or references to the client in the database. Historical data can include:
  • Receipts and adjustments
  • Service charges
  • Invoices
  • Time and expense transactions
  • References to the client or staff in on-screen filters, as well as report filters and report options.
  • Projects, completed and open (applies only if you have the Project Management Module)
  • Client interactions including notes, phone calls, and phone messages (applies only if you have the Client Management Module)
  • Scheduled items including scheduled phone calls, and to do's (applies only if you have the Staff Management Module)

Solution 1: Set the client or staff to Inactive (Recommended)

The recommended method for inactive clients or staff is to set the
Status
to
Inactive
, enter a
Left Date
, then change the
ID
to one that will cause it to sort to the bottom of the list. You can also create and use filters in lists, drop-downs, and reports that exclude inactive client or staff so they won't appear on screens or reports.

Solution 2: Delete all data in the client or staff

If you wish to continue, use
View Details
to find which types of historical data exist. Then follow the steps below to find and remove all data associated with the client or staff.
  1. Print a Service Charge Journal filtered for the client or staff.
  2. Starting with the newest service charge, go to
    Actions
    , then
    Assess Service Charges
    and enter the
    Through
    date equal to the newest date on the Journal.
  3. Find the service charge for this client and select the checkbox.
  4. Right-click and choose
    Unpost Selected
    .
  5. Repeat steps 3 and 4 for each date in reverse date order.
  1. Go to
    Actions
    , then
    Receipt & Adjustment Entry
    .
  2. If the Approve and Post process for Receipt & Adjustment Entry is on:
    1. Open the
      Review
      tab.
    2. Clear the
      Unapproved only
      and
      Unposted only
      checkboxes.
    3. Filter for the client or staff, then unpost and unapprove all control sheets on the screen.
  3. Go to the
    Overview
    tab.
  4. Filter for the client or staff.
  5. Mark the
    Control Date
    checkbox on the first transaction. Scroll to the last transaction and, while pressing the SHIFT key, select the
    Control Date
    checkbox in the last transaction. This will highlight every transaction.
  6. Right-click the
    Control Date
    checkbox on any transaction and choose
    Delete Entry
    .
  1. Go to
    Actions
    , then
    Billing
    .
  2. Open the
    Review
    tab.
  3. If the Approve and Post process for Billing is on, clear the
    Unapproved only
    and
    Unposted only
    checkboxes.
  4. Filter for the client or staff.
  5. Right-click and choose
    Select All
    .
  6. Right-click and choose
    Delete Selected
    .
  1. Go to
    Actions
    , then
    Time & Expense Entry
    .
  2. If the Approve and Post process for Time & Expense Entry is on:
    1. Open the
      Review
      tab.
    2. Clear the
      Unapproved only
      and
      Unposted only
      checkboxes.
    3. Filter for the client or staff, then unpost and unapprove all timesheets on the screen.
  3. Go to the
    Overview
    tab.
  4. Filter for the client or staff.
  5. Select the first transaction. Scroll to the last transaction and, while pressing the SHIFT key, select the last transaction. This will highlight every transaction.
  6. Right-click and choose
    Delete Entry
    .
  1. Go to
    Actions
    , then
    Manage Staff
    .
  2. Open the
    Schedule Items
    tab
  3. Select
    Custom Date Range
    then enter
    1/1/1980
    in the first date and
    12/31/2029
    in the second date.
  4. Clear the
    Open only
    and
    Unassigned only
    checkboxes.
  5. Filter for the staff.
  6. Right-click each schedule item and select
    Delete
    .
  1. Go to
    Actions
    , then
    Manage Projects
    .
  2. Filter for the client or staff.
  3. Clear the
    Open Projects only
    checkbox.
  4. Select the first project. Scroll to the end of the list and, while pressing the SHIFT key, select the last project. This will highlight every project.
  5. Right-click in the highlighted area and choose
    Delete Selected Projects
    .
  1. Go to
    Actions
    , then
    Manage Clients
    .
  2. Open the
    Interactions
    tab and filter for the client.
  3. Clear the
    Show last 30 days only
    checkbox.
  4. Select the first interaction. Scroll to the end of the list and, while pressing the SHIFT key, select the last interaction. This will highlight every interaction.
  5. Right-click in the highlighted area and select
    Delete Selected Interactions
    .