Error: timeout message when updating the
Workpapers CS
database to a newer version

Scenario

After installing an update, you may receive the following message while the
Workpapers CS
database is updating.
Error message
System.ApplicationException: Database schema update failed at lineā€¦ (Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding)...
If you receive this error message, check the size of your database file located in
C:\Program Files (x86)\Microsoft SQL Server\[Your SQL Instance]\MSSQL\Data\ACS_0_Firm.mdf
.

Cause 1

The database being updated will exceed the size limit for Microsoft SQL Server Express Edition. Review the following recommended solution. If the ACS_0_Firm.mdf file is equal or close to the limit, it's likely exceeding the limit.

Solution 1

Once the file size limit has been reached in Microsoft SQL Server Express Edition, it's necessary to upgrade to a Microsoft SQL Server Standard Edition or move to Virtual Office. For the short term, we would recommend moving back to the previous version to let you to continue processing. This will require uninstalling and re-installing Accounting CS and updating to the previous version. Follow these steps to revert back to the previous version:
  1. Uninstall
    Workpapers CS
    and
    Workpapers CS
    Shared Files.
  2. Go to the X:\WinCSI\
    Workpapers CS
    \updates folder, where X represents the drive letter where the program is installed.
  3. Delete the update file with the latest version number.
  4. Install
    Workpapers CS
    .
  5. Open
    Workpapers CS
    .
  6. Select
    Yes
    to
    Would you like to check for program updates?
  7. Unmark the
    Retrieve and apply available updates
    checkbox, select
    Apply previously downloaded updates/licenses
    , then select
    Apply Now
    .
  8. Once the updates apply, select
    Close
    , complete the update process, and open
    Workpapers CS
    .

Cause 2

The default time-out period needs to be extended due to a large amount of data being processed. Review the following recommended solution if the file size is less than 10 GB, or you're using a Microsoft SQL Server Standard Edition.

Solution 2

Extend the time-out period. A time out can happen when processing data takes longer than the allotted time to process. This can be due to an environmental factor causing a lag or hesitation during the process and/or a large amount of a specific type of data being processed. Follow these steps to increase the time allotted to one hour.
  1. Have everyone close
    Workpapers CS
    .
  2. Go to X:\WinCSI\
    Workpapers CS
    and open
    NetworkInstallation.ini
    with Notepad.
  3. Add
    SqlCommandTimeoutSeconds=3600
    after [appSettings].
  4. Save and close the file.
  5. Reopen
    Workpapers CS
    .

Cause 3

Security software can interfere with the update process.

Solution 3

Review your security applications.