Error: You have 10 days remaining on your license

Scenario

You may see one of the following error messages when you open your program.
Error message
Error: You have 10 days remaining on your license
Error: You have 10 days remaining on your partially-paid license

Cause

You may see this error if:
  • You haven't downloaded your updated licenses after renewing.
  • You haven't downloaded your updated licenses after paying off your financed renewal.
  • You haven't made your final payment on your financed renewal.

Solutions

Download your updated licenses in the program. You'll need to know your firm's License PIN.
If you financed your renewal and the license download fails, you have a payment due. Log in to your account on tax.tr.com and select
View orders with payments due
to pay your open invoices. After you pay the invoice, make sure you know your firm's License PIN and then download your updated licenses in the program.